Don't have an account? Click here to Register! Forgot password?

Updates - 17 June 2013  (Read 960 times)

Posted on 17 Jun 2013, 10:45:05
Outrack
This may not seem like a large update, but it took a while to fix the issue with embedding images directly from the gallery - I had to manually compare lines in the database to find the cause.

Things Fixed:
  • Fixed the placement of the username when logged in.
  • Fixed the height of the "login" button when logged out. It's slightly out by just 1px on Firefox, but looks better otherwise.
  • Changed colors on the message index to greyscale. This is one of those things most users wouldn't pick up on, but the previous slight blue tint looked bad against RAWR's purple scheme so it should match up better now (at least, it will when I upload the RAWR revisions).
  • Fixed JPEG avatars! You shouldn't have any more problems uploading them.
  • Changed the font color and type on the Calendar and Gallery. Not perfect as it's still processing unnatural bold in some places, but it's good enough.
  • Amended the look of the post buttons (post, preview, save draft) so that they reflect the rest of the layout.
  • Added custom icons on the forum index. Not too wild about them, but they at least break away from the default ones for now.
  • Images uploaded to the gallery no longer automatically resize if >1024px. This is an embarrassing oversight - I've set it to only resize if images are larger than 3000px now so please re-upload any images/screenshots that didn't maintain their correct size.
  • Made the colors in the logo stand out more, also removed beta as we're pretty much done with updates now (just one last one planned).
Still to do:
  • Update changes to the RAWR section. This isn't that hard to do, though I'd like to update the landing page to make it look better at the same time.
  • Add Karma back in. Still thinking of a good place to put the buttons...
  • Forgot to add the Facebook/Twitter buttons to cathead bar in posts again. Oops.
  • Add in some default avatars, get rid of the base SMF ones.
  • New icon for the spoiler tag in the text editor? Current one looks like it's supposed to launch a nuke...
  • Icons for user ranks so that people can differentiate between members that post a lot and forum staff.
To see the updates, empty your cache or stab ctrl+F5 until the "beta" disappears from the site logo. Let me know if you see anything that needs updating!

Posted on 17 Jun 2013, 12:56:30
ZellKFF
Thanks Nick, the site's looking better with each update :sparkle:

Is the gallery image fix retroactive? When I cick on embedded images in posts, they're still quite small and hard to see :/

Also, sometimes embedded gallery images' thumbnails will fail to load while loading up a thread, you'll ge the blank image with a red X at the top left. Refreshing fixes it usuall although if you have multiple gallery images in the same thread, sometimes another one will fail to load then. Are both DBs on the same server? It could be a communication problem.

And finally, it seems like all probie avatars are broken (default ones I imagine?), they show a red X too :D

RAWR guildmaster since 2004
Currently playing: RO2 - channel 5

Posted on 18 Jun 2013, 07:13:53
Outrack
The fix unfortunately isn't retroactive - the resized uploaded images larger than the specified size and then dropped the original from the server to save space, so you'll need to re-upload older images. Really sorry for the inconvenience, but at least we have batch uploading so it shouldn't take long adding everything again (let me know if you need any help removing/updating).

Not sure what's causing the broken images... Everything's stored on the same server and if there was a break in communication they should be down entirely - I'll rebuild all thumbnails/preview images again and hope that fixes it. Thanks for pointing out that the default avatars were broken, had a really hectic weekend and didn't get a chance to test them out ^^; All working now!

Edit: Rebuilt all images - I've just gone through the gallery and the RAWR screenshots thread and can't find any broken links, can you let me know if you're still having issues anywhere?
Last Edit: 18 Jun 2013, 07:37:23 by Outrack

Posted on 20 Jun 2013, 10:59:53
Outrack
Ugh... Okay, quick update regarding large images. I've managed to isolate the cause of images directly linked from the gallery resizing to 200x50 - the option for specifying a maximum width of images in posts is creating a (nonsensical) conflict and right now we can't have both features active.

I've installed a clean version of SMF 2.0.4 with just the Aeva mod and was able to successfully reproduce the conflict without any additional mods or template errors, so this is definitely a bug in the software and not in my updates. I honestly have no idea how to fix this, but I have posted a query on the SMF website so hopefully a dev will be able to point us in the right direction.

... Which is optimistic considering the developer of the Aeva mod abandoned the project to develop a fork of SMF because the team haven't released a goddamn update in ages.

Getting really tired of your shit, SMF.

EDIT: Went onto the old forum's archive as I thought it was weird we didn't notice the same issues before, and sure enough everything works perfectly fine there. The key difference is that the old site used SMF 2.0.2 while we're on 2.0.4 now, so the conflict has to be coming from SMF's side - I'll look around more and if I can't get a suitable answer I'll look into adapting all updates to an older version.
Last Edit: 20 Jun 2013, 11:07:58 by Outrack

Posted on 20 Jun 2013, 11:11:03
raela

(pretend Mewtwo is SMF)
~ raela (ML20 assassin) ~ naenia (ML1 sorcerer) ~ dasity (ML8 rogue) ~
~ sarinelle (ML1 priest) ~ nayrin (ML1 monk)  ~ kaysera (ML1 warrior) ~
 ~ acercia (25 beastmaster) ~ forgeria (30 wizard) ~ darkyne (ML13 soulmaker)  ~

Posted on 25 Jun 2013, 23:54:53
Lexy
Has automagic resizing (or lack thereof) been fixed for externally linked images? (genuine question, i'm browsing on my tablet and it's hard to navigate around screenshot threads D:)
\(❍ᴥ❍ʋ)

Lexy LoliPants

Posted on 27 Jun 2013, 08:33:09
Outrack
It hasn't - I've been trying to come up with a solution that doesn't involve downgrading our SMF version but support on their website is absolutely useless and I'm really not looking forward to porting over all template/css edits and fiddling around with mods to get things working.

I'm going to install a local copy of 2.0.2 and run an upgrade to 2.0.4 to see if that remedies the issue. Sorry for the issues with images, this has been incredibly frustrating :cry:

Posted on 08 Jul 2013, 22:45:23
Outrack
Direct image embedding from the gallery and avatars have both been fixed. I'm really sorry that it's taken so long, lost all motivation to keep working on problems I felt shouldn't exist and wound up having to manually check each of the tables in the database to isolate the cause of the bugs.

I may work in another update to bring back the Karma system, though at this point I feel like my attention should be directed at building an independent forum that will cater to our needs specifically :sparkle:

Posted on 08 Jul 2013, 23:00:49
Allucinari

There, I fixed it for you raela.

Also um.. happy coding? This sounds like a huge undertaking and I have no skills to offer in the helping department.

[edit]
OH GOD MY BEAR YOU FIXED MY BEAR, who cares about these other problems, forums are fine, got my bear back..
[/edit]
ヽʕ•ᴥ•ʔノ✿

 

SMF 2.0.4 | SMF © 2013, Simple Machines
SimplePortal 2.3.5 © 2013