Don't have an account? Click here to Register! Forgot password?

Welcome to ashtear.net ver. 3!  (Read 3146 times)

Posted on 15 May 2013, 21:16:22
Outrack
I'd like to type something more welcoming, but my hands are bloody cold and it's just gone past 3am so I'll leave it for the morning (when I'll start posting around everywhere telling everyone about the relaunch).

Hope everyone likes the new design! While not perfect, I'm proud of how it came out as I've had something like this in mind for years and thought it was impossible to do under SMF.

Things to do:
  • Add neko smileys.
  • Add RAWR section/s.
  • Add custom BBCode for video embeds, floats...
  • The user section in the thread display needs work - better icons, styling, etc
  • Need better styling for quotes.

List of known bugs:
NOTE - the items marked as fixed here are only things I've sorted on my local copy of the site; just using this to keep track of everything and will update w/ fixes once I've got most of them clear.
  • Firefox shows the search bar two pixels lower than it should be, and the "Read your messages" text falls to two lines instead of just one. Fixed: the line-height property was the culprit.
  • Search bar appears 2px larger in Firefox, bleeding over the menu bar. Fixed by adjusting the height - strangely made it smaller in FF while retaining the desired size in Chrome/IE.
  • Icons in the top bar don't retain their highlight when browsing over the items in the drop-down menu.
  • Bold text looks horrible. I'm not sure if it's something I've done or if it's on Google Font's side, but I'll transfer all font files to a local source and hope that fixes it. Fixed: set OpenSans Semibold as the default font for the strong and b tags. Not sure if Semibold is as good as regular Bold, but it's easy enough switching between the two.
  • Font in WYSIWYG editor is set to Verdana instead of Open Sans. No easy fix, going to just disable the damn thing.
  • Don't like all the colors in the body, specifically on the forum's landing and message index. It's kind of minor, but still worth looking into.
  • There's a ~10px white space at the bottom of the page on the portal, under the copyright/social icons bar. EDIT: Being caused my the Portal Copyright - weird as it isn't on my local copy. Maybe it'll go when I re-upload everything... Fixed.
  • Bottom bar doesn't always appear at the end of the page when there isn't enough stuff to space out the screen. Fixed using the min-height property.
  • Kero and Kurie reported that they can't upload avatars - I had no problem and Lexy didn't seem to either, so I have no bloody idea what's causing it. Please let me know if any of you have the same thing happening! Found out that it was happening with JPG images, looking into it. In the meantime, please convert all avatars to either GIF or PNG if you have problems uploading.
  • WYSIWYG editor is still embedding double lines. Disabled the editor for now, was told the issue might be fixed in 2.1, Hope I don't have to reskin the whole bloody thing again...
  • Broke the quick editor. Totally my fault, but regular Modify still works so I see this as non-essential.
  • User Info block on the portal shows a scrollbar - possible easy fix if I adjust the width/height.
  • The Calendar was disabled as it pushes items to a new level in the navbar; can be fixed by increasing the width. Fixed: Calendar is back.
If you see anything I haven't noted here, please let me know!
Last Edit: 28 May 2013, 12:22:12 by Outrack

Posted on 15 May 2013, 22:05:39
Allucinari
No problem uploading avatars for me.


Awesome work, it looks fantastic.
ヽʕ•ᴥ•ʔノ✿

Posted on 16 May 2013, 09:10:16
Icosix
Huzzah!

You're also missing a style on the navigation bar: when you hover over the active page link it changes to the hover style instead of staying active. Not sure if intentional.

Posted on 16 May 2013, 14:28:14
ZellKFF
Awesome work Nick <3 It looks beautiful.

I could even get used to Allu's flashing unicorn. After I recover from my first 3 seizures.

RAWR guildmaster since 2004
Currently playing: RO2 - channel 5

Posted on 16 May 2013, 17:29:17
Spud
Such awesome work, Nick! If you need help fixing some bugs let me know, I'd be happy to help.

Posted on 17 May 2013, 03:13:17
Carlos
I approve of this, game on dawgs!

Posted on 17 May 2013, 15:21:24
Outrack
Just letting you guys know I've updated the theme and crossed out the issues I've listed in my opening post. If you haven't seen the changes, stab Ctrl+F5 a couple of times to empty your cache - there are still a couple of things that need fixing but we're slowly getting there.

Posted on 17 May 2013, 19:22:40
Allucinari
I could even get used to Allu's flashing unicorn. After I recover from my first 3 seizures.

Yesssss, Mission Accomplished.   :sparkle:
ヽʕ•ᴥ•ʔノ✿

Posted on 20 May 2013, 21:18:30
Sheepy
It would be nice if you didn't have to delete the word "SEARCH" from the search box before every use too. (or highlight and write)

Posted on 21 May 2013, 23:23:33
Lexy
RAWR guild area shows:
0 Topics
0 Posts

Probably because it's all made up of subforums...
\(❍ᴥ❍ʋ)

Lexy LoliPants

Posted on 24 May 2013, 08:47:15
Outrack
It would be nice if you didn't have to delete the word "SEARCH" from the search box before every use too. (or highlight and write)

Mentioned it in IRC, but just confirming that I know about the problem and am working on it.

RAWR guild area shows:
0 Topics
0 Posts

Probably because it's all made up of subforums...

Going to see if I can find a way of having all subforum numbers contribute to the overall... It is kind of bad as it is right now :<

Other issues I'm working on:
  • PM number indicator shows total messages in your inbox, not unread messages.
  • Username in the toolbar is slightly higher than it should be, need to knock it down by around 2-4px.
  • Some Emoticons missing, including the full star Done!
  • Going to try forcing signatures to the bottom with the min-height property when posts are only one or two lines long.
  • Lower emoticon limit in posts. Thanks Jack! Can't do this without a mod, will just ban the next person who spams.
  • Update "Last Edited By" text to make it more appealing.
  • Add Facebook/Twitter buttons to cathead bar in posts.
  • Update userbar in posts; amend changes to PMs. Also need to figure out which PM settings we were using on the old site, I'd kill for a simple inbox system like every other forum has...
  • Apply index styling to subforums, the RAWR section's using SMF's default structure.
Last Edit: 28 May 2013, 12:23:39 by Outrack

Posted on 25 May 2013, 19:57:20
Lexy
It would be nice if you didn't have to delete the word "SEARCH" from the search box before every use too. (or highlight and write)

Mentioned it in IRC, but just confirming that I know about the problem and am working on it.

Not sure how much of the code you can edit but just change value="Search" to placeholder="Search" in this line:

<input class="index_input" type="text" value="SEARCH" name="search"></input>

Also when you do click on the search and then move your mouse out of it, the box moves down 2 pixels :| (on Firefox)
\(❍ᴥ❍ʋ)

Lexy LoliPants

Posted on 25 May 2013, 23:41:41
Spud
It would be nice if you didn't have to delete the word "SEARCH" from the search box before every use too. (or highlight and write)

Mentioned it in IRC, but just confirming that I know about the problem and am working on it.

Not sure how much of the code you can edit but just change value="Search" to placeholder="Search" in this line:

<input class="index_input" type="text" value="SEARCH" name="search"></input>

Also when you do click on the search and then move your mouse out of it, the box moves down 2 pixels :| (on Firefox)

I think he knows about the 2px down thing, at least for Chrome I know he is.

Outrack, Lexy is right @ placeholder, it's the easiest way without adding JS to the input. It's pretty well supported too.

Posted on 26 May 2013, 09:16:01
Outrack
Already fixed the search text in my local copy, just wanted to sound productive :sparkle: Still no clue on what's happening with the border when losing focus on the search field, as far as I can tell the CSS is fine - I built the bar on its own and the copy I've got works as it should, so I'm thinking that something in the base SMF design is conflicting with it. Or I left something out accidentally because I'm usually really tired when doing this...

I'll upload the next update when I've fixed most of the issues listed.

Posted on 28 May 2013, 11:29:24
Outrack
RAWR guild area shows:
0 Topics
0 Posts

Probably because it's all made up of subforums...

Fixed!

Finally got around to sorting out most of the issues, will update the site later on this evening when I've got around 80% of the problems done.

 

SMF 2.0.4 | SMF © 2013, Simple Machines
SimplePortal 2.3.5 © 2013